|SND_AI2S(4)||FreeBSD Kernel Interfaces Manual||SND_AI2S(4)|
NAMEsnd_ai2s — Apple I2S audio device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe snd_ai2s driver provides support for the Apple I2S audio controllers found predominantly in G4 and G5 machines, along with the snapper and tumbler codecs. Some machines (e.g. the Mac Mini) do not have configurable codecs and so lack hardware volume control.
HARDWAREChips supported by the snd_ai2s driver include:
- Apple Tumbler Audio
- Apple Snapper Audio
HISTORYThe snd_ai2s device driver appeared in NetBSD 2.0 and then in FreeBSD 8.0.
AUTHORSThe snd_ai2s driver was written by <firstname.lastname@example.org>, and ported to FreeBSD by <email@example.com>.
BUGSRecording and operation with non-44.1 Khz audio are not currently supported.
|January 20, 2009||FreeBSD|