|SMU(4)||FreeBSD Kernel Interfaces Manual||SMU(4)|
NAMEsmu — Apple System Management Unit Driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
DESCRIPTIONThe smu driver provides support for the System Management Unit (SMU) found in many Apple G5 systems. This includes most Power Macintosh G5 and all iMac G5 systems.
The Apple SMU controller provides software power management and thermal control functionality, and is responsible for managing system cooling devices.
HARDWAREChips supported by the smu driver include:
- Apple System Management Unit
THERMAL MANAGEMENTThe smu driver provides basic automatic thermal management. Without a userspace daemon providing more advanced control, the driver will attempt to maintain system temperatures in a conservative range through coarse-grained control of system cooling devices (see below). Automatic kernel-level thermal control will take over if more than 3 seconds elapses between userspace cooling setting adjustments.
SYSCTL VARIABLESThe smu driver provides power management services and thermal readout through a sysctl interface. The following sysctls can be used to control the power management behavior and to examine current system power and thermal conditions.
- Restart after power failure behavior (1 causes system to reboot after power cut, 0 causes system to remain off).
- Target system temperature, in degrees Celsius. The smu driver will attempt to adjust fans to maintain the temperature of the warmest component in the system at or below this level.
- System critical temperature, in degrees Celsius. If any component in the system exceeds this temperature, the machine will be shut down within 500 ms.
- Minimum allowed speed for this fan.
- Maximum allowed speed for this fan.
- Current speed for this fan. The fan speed can be adjusted by changing this sysctl. If more than 3 seconds elapses between fan speed adjustments, the kernel will resume automatic control of the fan.
- Current reading from this sensor. Four sensor types are supported. Temperature sensors are in units of degrees Celsius, current sensors in milliamps, voltage sensors in millivolts, and power sensors in milliwatts.
LED INTERFACEThe smu driver provides an led(4) annunciator interface at /dev/led/sleepled.
HISTORYThe smu device driver appeared in FreeBSD 8.0.
AUTHORSThe smu driver was written by <nwhitehorn@FreeBSD.org>.
|February 22, 2010||FreeBSD|