|PMU(4)||FreeBSD Kernel Interfaces Manual||PMU(4)|
NAMEpmu — Apple PMU99 Power Management Driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
DESCRIPTIONThe pmu driver provides support for the Power Management Unit (PMU) found in Apple Core99 hardware. This includes late G3 laptops, all G4 machines, early G5 desktops and all G5 XServes.
The Apple PMU controller is a multi-purpose ASIC that provides power management and thermal control, as well as an ADB bus for the internal keyboard and mouse on laptops.
HARDWAREChips supported by the pmu driver include:
- Apple KeyLargo PMU
- Apple K2-KeyLargo PMU
SYSCTL VARIABLESThe pmu driver provides power management services in addition to an adb(4) interface. The following sysctls can be used to control the power management behavior and to examine current system power and thermal conditions.
- Restart after power failure behavior (1 causes system to reboot after power cut, 0 causes system to remain off).
- Indicates whether the relevant battery is inserted.
- Indicates whether the battery is currently charging.
- The current battery charge, in milliamp hours.
- The battery's self-reported maximum charge, in milliamp hours.
- The current into the battery, in milliamps. While the battery is discharging, this will be negative.
- Battery voltage, in millivolts.
- Estimated time until full battery charge (or discharge), in minutes.
- Current fraction of the battery's maximum charge, in percent.
HISTORYThe pmu device driver appeared in NetBSD 4.0, and then in FreeBSD 8.0.
AUTHORSThe pmu driver was written by <macallan@NetBSD.org> and ported to FreeBSD by <nwhitehorn@FreeBSD.org>.
|December 6, 2008||FreeBSD|