|VX(4)||FreeBSD Kernel Interfaces Manual (i386)||VX(4)|
NAMEvx — 3Com EtherLink III / Fast EtherLink III (3c59x) Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe vx driver provides support for the 3Com “Vortex” chipset.
The medium selection can be influenced by the following link flags to the ifconfig(8) command:
- Use the AUI port.
- Use the BNC port.
- Use the UTP port.
HARDWAREThe vx driver supports the following cards:
- 3Com 3c590 EtherLink III PCI
- 3Com 3c592 EtherLink III EISA
- 3Com 3c595 Fast EtherLink III PCI in 10 Mbps mode
- 3Com 3c597 Fast EtherLink III EISA in 10 Mbps mode
- vx%d: not configured; kernel is built for only %d devices.
- There are not enough devices in the kernel configuration file for the number of adapters present in the system. Add devices to the configuration file, rebuild the kernel, and reboot.
All other diagnostics indicate either a hardware problem or a bug in the driver.
HISTORYThe vx device driver first appeared in FreeBSD 2.1. It was derived from the ep driver, from which it inherits most of its limitations.
AUTHORSThe vx device driver and this manual page were written by <firstname.lastname@example.org>, based on the work of and with the assistance of numerous others.
CAVEATSSome early-revision 3c590 cards are defective and suffer from many receive overruns, which cause lost packets. The author has attempted to implement a test for it based on the information supplied by 3Com, but the test resulted mostly in spurious warnings.
The performance of this driver is somewhat limited by the fact that it uses only polled-mode I/O and does not make use of the bus-mastering capability of the cards.
BUGSThe vx driver is known not to reset the adapter correctly following a warm boot on some systems.
The vx driver has not been exhaustively tested with all the models of cards that it claims to support.
|July 16, 2005||FreeBSD|