|VPD(4)||FreeBSD Kernel Interfaces Manual (i386)||VPD(4)|
NAMEvpd — Vital Product Data kernel interface
DESCRIPTIONIBM ThinkPad notebooks (and most IBM desktop PCs) have a 48-byte Vital Product Data (VPD) structure located in the BIOS Shadow RAM.
The VPD provides machine type and model information, the build ID (this is roughly the BIOS version) and serial number information.
The vpd driver scans the BIOS area and claims the memory used by the VPD structure. It provides the sysctl(3) branch hw.vpd to allow this information to be accessed by the userland. The following variables are provided, one per VPD attachment (there should only be one):
- ( machine.type) Machine type.
- ( machine.model) Machine model.
- ( build.id) BIOS Build ID.
- ( serial.box) Box Serial Number.
- ( serial.planar) Motherboard Serial Number.
SEE ALSOTP General - Using the BIOS Build ID to identify IBM ThinkPad systems, Reference #: MIGR-45120, http://www.ibm.com/support/docview.wss?uid=psg1MIGR-45120, November 22, 2002.
HISTORYThe vpd driver first appeared in FreeBSD 5.1.
AUTHORSThe vpd driver and this manual page were written by <mdodd@FreeBSD.org>.
|August 31, 2004||FreeBSD|