|CX(4)||FreeBSD Kernel Interfaces Manual (i386)||CX(4)|
NAMEcx — driver for synchronous/asynchronous Cronyx Sigma WAN adapters
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe cx driver needs either sppp(4) or netgraph(4). Which one to use is determined by the NETGRAPH_CRONYX option. If this option is present in your kernel configuration file, the cx driver will be compiled with netgraph(4) support. Otherwise, it will be compiled with sppp(4) support.
The base I/O port address specified in /boot/device.hints must match the port address set by the jumpers on the board. The DMA I/O channel and interrupt request numbers are configured by software at adapter initialization. Legal values are:
- 0x240, 0x260, 0x280, 0x300, 0x320, 0x380
- 3, 5, 7, 10, 11, 12, 15
- 5, 6, 7
The cx driver supports autodetection. As for all non-PNP hardware, using autodetection could lead to some potential problems with other devices during the hardware detection process. It is always better to specify hardware resources manually.
Refer to sconfig(8) for information about the cx adapter configuration.
HARDWAREThe cx driver supports the following cards:
- Cronyx Sigma-22, Sigma-24
- Cronyx Sigma-100
- Cronyx Sigma-400, Sigma-401, Sigma-404, Sigma-410, Sigma-440
- Cronyx Sigma-500
- Cronyx Sigma-703
- Cronyx Sigma-800, Sigma-801, Sigma-810, Sigma-840
HISTORYThe cx driver was updated in FreeBSD 5.2 and FreeBSD 4.10. In most of the previous versions of FreeBSD the cx driver is out of date. The cx driver for previous versions of FreeBSD is available from http://www.cronyx.ru/.
|July 16, 2005||FreeBSD|