|SFXGE(4)||FreeBSD Kernel Interfaces Manual||SFXGE(4)|
NAMEsfxge — Solarflare 10Gb Ethernet adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
To load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe sfxge driver provides support for 10Gb Ethernet adapters based on Solarflare SFC9000 family controllers. The driver supports jumbo frames, transmit/receive checksum offload, TCP Segmentation Offload (TSO), Large Receive Offload (LRO), VLAN checksum offload, VLAN TSO, and Receive Side Scaling (RSS) using MSI-X interrupts.
The driver allocates 1 receive queue, transmit queue, event queue and IRQ per CPU up to a maximum of 64. IRQ affinities should be spread out using cpuset(1). Interrupt moderation may be controlled through the sysctl dev.sfxge.%d.int_mod (units are microseconds).
For more information on configuring this device, see ifconfig(8).
A large number of MAC, PHY and data path statistics are available under the sysctl dev.sfxge.%d.stats. The adapter's VPD fields including its serial number are available under the sysctl dev.sfxge.%d.vpd.
HARDWAREThe sfxge driver supports all 10Gb Ethernet adapters based on Solarflare SFC9000 family controllers.
SUPPORTFor general information and support, go to the Solarflare support website at: https://support.solarflare.com.
AUTHORSThe sfxge driver was written by and
|February 8, 2012||FreeBSD|