|IDA(4)||FreeBSD Kernel Interfaces Manual||IDA(4)|
NAMEida — Compaq Intelligent Drive Array Controllers
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe Compaq Intelligent Drive Array (IDA) technology is used to distribute data across an array of hard drives. It unites these hard drives into one or more high-performance logical drives. The drive array is managed by an array controller.
These controllers have the ability to provide fault tolerance for the connected drives and optionally provide write cache for the logical drives. It is also possible for an application to access the SCSI bus subsystem directly by using the pass-through interface.
HARDWAREThe following controllers are supported by the ida driver:
- Compaq SMART Array 221
- Compaq Integrated SMART Array Controller
- Compaq SMART Array 4200
- Compaq SMART Array 4250ES
- Compaq SMART 3200 Controller
- Compaq SMART 3100ES Controller
- Compaq SMART-2/DH Controller
- Compaq SMART-2/SL Controller
- Compaq SMART-2/P Controller
- Compaq SMART-2/E Controller
- Compaq SMART Controller
IMPLEMENTATION NOTESExtreme caution should be exercised when using the pass-through interface. It is possible to interfere with normal system I/O and cause hangs if pass-through is used to an active device. Pass-through should only be used to a device that is otherwise quiescent.
AUTHORSThe ida driver was written by <jlemon@FreeBSD.org> and <mdodd@FreeBSD.org>. This manual page was written by <trhodes@FreeBSD.org>.
|August 8, 2004||FreeBSD|