|HYPER-V(4)||FreeBSD Kernel Interfaces Manual||HYPER-V(4)|
NAMEhv_storvsc — Hyper-V Storage Virtual Service Consumer
SYNOPSISTo compile this driver into the kernel, place the following lines in the system kernel configuration file:
DESCRIPTIONThe hv_storvsc driver implements the virtual store device for FreeBSD guest partitions running on Hyper-V. FreeBSD guest partitions running on Hyper-V do not have direct access to storage devices attached to the Hyper-V server. Although a FreeBSD guest can access storage devices using Hyper-V's full emulation mode, the performance in this mode tends to be unsatisfactory.
To counter the above issues, the hv_storvsc driver implements a storage Virtual Service Consumer (VSC) that relays storage requests from the guest partition to the storage Virtual Service Provider (VSP) hosted in the root partition using the high performance data exchange infrastructure provided by hv_vmbus(4) driver. The VSP in the root partition then forwards the storage related requests to the physical storage device.
This driver functions by presenting a SCSI HBA interface to the Comman Access Method (CAM) layer. CAM control blocks (CCBs) are converted into VSCSI protocol messages which are delivered to the root partition VSP over the Hyper-V VMBus.
HISTORYSupport for hv_storvsc first appeared in FreeBSD 10.0. The driver was developed through a joint effort between Citrix Incorporated, Microsoft Corporation, and Network Appliance Incorporated.
AUTHORSFreeBSD support for hv_storvsc was first added by <firstname.lastname@example.org>.
|September 10, 2013||FreeBSD|