|HYPER-V(4)||FreeBSD Kernel Interfaces Manual||HYPER-V(4)|
NAMEhv_netvsc — Hyper-V Network Virtual Service Consumer
SYNOPSISTo compile this driver into the kernel, place the following lines in the system kernel configuration file:
DESCRIPTIONThe hv_netvsc driver implements the virtual network device for FreeBSD guest partitions running on Hyper-V. FreeBSD guest partitions running on Hyper-V do not have direct access to network devices attached to the Hyper-V server. Although a FreeBSD guest can access network devices using Hyper-V's full emulation mode, the performance in this mode tends to be unsatisfactory.
To counter the above issues, the hv_netvsc driver implements a network Virtual Service Consumer (VSC) that relays network requests from the guest partition to the network Virtual Service Provider (VSP) hosted in the root partition using the high performance data exchange infrastructure provided by hv_vmbus(4) driver. The VSP in the root partition then forwards the network related requests to the physical network card.
HISTORYSupport for hv_netvsc first appeared in FreeBSD 10.0. The driver was developed through a joint effort between Citrix Incorporated, Microsoft Corporation, and Network Appliance Incorporated.
AUTHORSFreeBSD support for hv_netvsc was first added by <firstname.lastname@example.org>.
|September 10, 2013||FreeBSD|