|FDTBUS(4)||FreeBSD Kernel Interfaces Manual||FDTBUS(4)|
NAMEfdtbus — Flattened Device Tree bus driver
DESCRIPTIONThe fdtbus abstract bus driver is the primary connection and translation layer between fdt(4) hardware resources description and FreeBSD native newbus device drivers framework. For an embedded system fdtbus represents peripherals typically found on a highly integrated chip (system-on-chip).
The fdtbus driver provides generic, common infrastructure for all fdt(4) oriented device drivers, and its main responsibilities are the following:
- Creating newbus children that reflect fdt(4) nodes in the flattened device tree.
- Managing SYS_RES_IRQ resources.
- Managing SYS_RES_MEMORY, SYS_RES_IOPORT resources.
STANDARDSIEEE Std 1275: IEEE Standard for Boot (Initialization Configuration) Firmware: Core Requirements and Practices ( Open Firmware).
Power.org Standard for Embedded Power Architecture Platform Requirements ( ePAPR).
HISTORYThe fdtbus support first appeared in FreeBSD 9.0.
AUTHORSThe fdtbus support was developed by Semihalf under sponsorship from the FreeBSD Foundation. This manual page was written by .
|July 12, 2010||FreeBSD|