|BKTR(4)||FreeBSD Kernel Interfaces Manual||BKTR(4)|
NAMEbktr — Brooktree Bt848/849/878/879 and Pinnacle PCTV video capture driver
DESCRIPTIONThe bktr driver provides support for PCI video capture and VBI capture on low cost, high performance boards. The driver is based on the Matrox Meteor driver and uses the same API. The bktr driver should support most video cards based on the Brooktree Bt848/849/878/879 Video Capture Chip. Also supported are most Pinnacle PCTV video cards. Furthermore, the driver supports FM Radio if the tuner supports it.
The driver currently supports the following features:
PCI to PCI dma transfer clipping yuv rgb16 rgb24 rgb32
On the supported cards, tuners and other components are interconnected with an I2C bus. The Brooktree848 chips act as a master device on the bus to control them. Therefore, iicbus(4), iicbb(4) and smbus(4) controller declarations are mandatory to activate bktr support.
The following kernel parameters may be used to further configure the driver:
options BROOKTREE_ALLOC_PAGES=xxx specifies the number of contiguous pages to allocate when successfully probed. The default number of pages allocated by the kernel is 216. This means that there are (216*4096) bytes available for use.
options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_PAL options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_NTSC
One of these options can be used to set the default video format for the driver. This fixed random hangs and lockups with the VideoLogic Captivator PCI card.
The following sysctls may be used to further configure the driver:
sysctl hw.bt848.card=nnnn This can be used to override the card make which was detected at boot time. ‘
nnnn’ is set to an integer from 1 to 23 taken from the following table:
sysctl hw.bt848.tuner=nnnn This can be used to override the tuner make which was detected at boot time. ‘
nnnn’ is set to an integer from 0 to 16 taken from the following table:
- 9 /* These have FM Radio support */
- 10 /* These have FM Radio support */
- 11 /* These have FM Radio support */
HARDWAREThe bktr driver supports video capture cards based on the Brooktree Bt848/849/878/879 chips, as well as Pinnacle PCTV cards, including:
- AOpen VA1000
- AVerMedia AVerTV Studio
- AVerMedia TF/FM-98
- ATI TV Wonder VE
- Hauppauge WinCast/TV
- Hauppauge WinTV-Go-FM
- Hauppauge WinTV-pci
- Hauppauge WinTV-radio
- Intel Smart Video Recorder III
- KWORLD PCI TV Tuner
- Miro PC TV
- Pinnacle PCTV Pro
- Pinnacle PCTV Rave
- PixelView PlayTV PAK
- PixelView PlayTV Pro (rev 4C, 9D)
- SIGMA TV II
- STB TV PCI Television Tuner
- Super TV Tuner
- TerraTec TValue
- V-Stream XPERT TV-PVR 878
- Video Highway XTreme
- VideoLogic Captivator PCI
- Examples of what you can do with the (similarly designed) Meteor driver.
- A TV and Camera display program utilizing the bktr driver - requires that The X Window System and The Ports Collection also be installed.
- A program to capture and display Teletext (VideoText) pages - requires that The X Window System and The Ports Collection also be installed.
- An FM Radio Tuner for cards which have an FM Radio tuner fitted - requires that The X Window System and The Ports Collection also be installed. It also requires Motif or the lesstif port.
HISTORYThe bktr driver first appeared in FreeBSD 2.2.
AUTHORSThis driver is based on the work of <firstname.lastname@example.org>, <email@example.com>, <firstname.lastname@example.org>, <roger@FreeBSD.org> and a bunch of other people. Support for Pinnacle PCTV Rave cards was added by <email@example.com>.
|January 18, 2006||FreeBSD|