EN JA
LINT(7)
LINT(7) FreeBSD Miscellaneous Information Manual LINT(7)

名称

lintlint エラーメッセージリスト

解説

次は、 lint(1) によって発生されるメッセージ ID とメッセージのリストです。 lint(1)-X フラグで使用されることを目的としています。
0 syntax error: empty declaration
 構文エラー: 空の宣言
1 old style declaration; add int
 古いスタイル宣言; int を加えてください
2 empty declaration
 空の宣言
3 %s declared in argument declaration list
 引数宣言リスト中で宣言された %s
4 illegal type combination
 不正なタイプの組み合わせ
5 modifying typedef with '%s'; only qualifiers allowed
  '%s' で変更された typedef;許可された修飾語句のみ
6 use 'double' instead of 'long float'
  'long float' の代わり 'double' を使用
7 only one storage class allowed
 許可された 1 つの記憶域クラスのみ
8 illegal storage class
 不正な記憶域クラス
9 only register valid as formal parameter storage class
 正式のパラメータ記憶域クラスとして有効なレジスタのみ
10 duplicate '%s'
  '%s' の重複
11 bit-field initializer out of range
 範囲外のビットフィールド初期化子
12 compiler takes size of function
 コンパイラは関数のサイズを取ります
13 incomplete enum type: %s
 不完全な列挙タイプ: %s
14 compiler takes alignment of function
 コンパイラは関数の整列を取ります
15 function returns illegal type
 関数は不正なタイプを返します
16 array of function is illegal
 関数の配列は不正です
17 null dimension
 空の次元
18 illegal use of 'void'
  'void' の不正な使用
19 void type for %s
  %s のための void タイプ
20 zero or negative array dimension
  0 か負の配列次元
21 redeclaration of formal parameter %s
 正式パラメータ %s の再宣言
22 incomplete or misplaced function definition
 不完全か見当違いの関数定義
23 undefined label %s
 未定義のラベル %s
24 cannot initialize function: %s
 関数を初期化できない: %s
25 cannot initialize typedef: %s
  typedef を初期化できない: %s
26 cannot initialize extern declaration: %s
 外部宣言を初期化できない: %s
27 redeclaration of %s
  %s の再宣言
28 redefinition of %s
  %s の再定義
29 previously declared extern, becomes static: %s
 以前に宣言された extern が static になる: %s
30 redeclaration of %s; ANSI C requires static
  %s の再宣言; ANSI C は static を必要とする
31 incomplete structure or union %s: %s
 不完全な構造体か共用体 %s: %s
32 argument type defaults to 'int': %s
 引数タイプのデフォルトを 'int' とする: %s
33 duplicate member name: %s
 重複したメンバ名: %s
34 nonportable bit-field type
 移植性のないビットフィールドタイプ
35 illegal bit-field type
 不正なビットフィールドタイプ
36 illegal bit-field size
 不正なビットフィールドタイプ
37 zero size bit-field
 サイズが 0 のビットフィールド
38 function illegal in structure or union
 構造体か共用体中の不正な関数
39 illegal zero sized structure member: %s
 不正な 0 のサイズの構造体のメンバ: %s
40 unknown size: %s
 未知のサイズ: %s
41 illegal use of bit-field
 ビットフィールドの不正使用
42 forward reference to enum type
 列挙タイプへの先方参照
43 redefinition hides earlier one: %s
 再定義は以前のものを隠します: %s
44 declaration introduces new type in ANSI C: %s %s
 宣言は ANSI C で新しいタイプを導入します: %s %s
45 base type is really '%s %s'
 ベースタイプは本当 '%s %s'
46 (%s) tag redeclared
  (%s) タグは再宣言しました
47 zero sized %s
  0 サイズの %s
48 overflow in enumeration values: %s
 列挙型の値でオーバフロー: %s
49 struct or union member must be named
 構造体か共用体のメンバは名前を付けなければなければなりません
50 a function is declared as an argument: %s
 関数は引数として宣言されます: %s
51 parameter mismatch: %d declared, %d defined
 パラメータ不一致: %d 宣言, %d 定義
52 cannot initialize parameter: %s
 パラメータを初期化できない: %s
53 declared argument %s is missing
 宣言された引数 %s が不足
54 trailing ',' prohibited in enum declaration
 列挙型宣言で禁止されている後続する ','
55 integral constant expression expected
 予想された整数定数式
56 integral constant too large
 整数定数が大きすぎ
57 enumeration constant hides parameter: %s
 列挙型定数はパラメータを隠します: %s
58 type does not match prototype: %s
 タイプはプロトタイプに一致しない: %s
59 formal parameter lacks name: param #%d
 正式パラメータは名前が不足: param #%d
60 void must be sole parameter
  void は唯一のパラメータでなければなりません
61 void parameter cannot have name: %s
  void パラメータは名前を持つことができません: %s
62 function prototype parameters must have types
 関数プロトタイプパラメータにはタイプがなければなりません
63 prototype does not match old-style definition
 プロトタイプは古いスタイル定義に合いません
64 ()-less function definition
  () のない関数定義
65 %s has no named members
  %s には名前が付いたメンバがない
66 syntax requires ';' after last struct/union member
 構文は最後の構造体/共用体の後に ';' を必要とします
67 cannot return incomplete type
 不完全なタイプを返すことができません
68 typedef already qualified with '%s'
  typedef は既に '%s' で修飾されている
69 inappropriate qualifiers with 'void'
  'void' がある不適当な修飾子
70 %soperand of '%s' is unsigned in ANSI C
  '%s' の %soperand は ANSI C で符号なしです
71 too many characters in character constant
 文字定数であまりに多くの文字
72 typedef declares no type name
  typedef 宣言にタイプ名がない
73 empty character constant
 空の文字定数
74 no hex digits follow \x
 \x に 16 進数が続かない
75 overflow in hex escape
  16 進エスケープでオーバフロー
76 character escape does not fit in character
 文字エスケープが文字に適合しません
77 bad octal digit %c
 不正な 8 進数字 %c
78 nonportable character escape
 移植性のない文字エスケープ
79 dubious escape \%c
 疑わしいエスケープ\%c
80 dubious escape \%o
 疑わしいエスケープ\%o
81 \a undefined in traditional C
 伝統的な C で未定義の\a
82 \x undefined in traditional C
 伝統的な C で未定義の\x
83 storage class after type is obsolescent
 タイプの後の記憶域クラスは旧式です
84 ANSI C requires formal parameter before '...'
  ANSI C は '...' の前に正式パラメータを必要とします
85 dubious tag declaration: %s %s
 疑わしいタグ宣言: %s %s
86 automatic hides external declaration: %s
 オートマチックは外部の宣言を隠します: %s
87 static hides external declaration: %s
  static は外部の宣言を隠します: %s
88 typedef hides external declaration: %s
  typedef は外部の宣言を隠します: %s
89 typedef redeclared: %s
 再宣言された typedef: %s
90 inconsistent redeclaration of extern: %s
  extern の矛盾した再宣言: %s
91 declaration hides parameter: %s
 宣言はパラメータを隠します: %s
92 inconsistent redeclaration of static: %s
  static の矛盾した再宣言: %s
93 dubious static function at block level: %s
 ブロックレベルにおける疑わしい static 関数: %s
94 function has illegal storage class: %s
 関数には不正な記憶域クラスがあります: %s
95 declaration hides earlier one: %s
 宣言は以前のものを隠します: %s
96 cannot dereference non-pointer type
 非ポインタタイプは修飾参照できません
97 suffix U is illegal in traditional C
 接尾辞 U は伝統的な C で不正です
98 suffixes F and L are illegal in traditional C
 接尾辞 F と L は伝統的な C で不正です
99 %s undefined
  %s が未定義です
100 unary + is illegal in traditional C
 単項 + は伝統的な C で不正です
101 undefined struct/union member: %s
 未定義の構造体/共用体: %s
102 illegal member use: %s
 不正なメンバ使用: %s
103 left operand of '.' must be struct/union object
  '.' の左オペランドは構造体/共用体のオブジェクトでなければ
 なりません
104 left operand of '->' must be pointer to struct/union
  '->' の左オペランドは構造体/共用体へのポインタでなければ
 なりません
105 non-unique member requires struct/union %s
 ユニークでないメンバは構造体/共用体を必要とします
106 left operand of '->' must be pointer
  '->' の左オペランドはポインタでなければなりません
107 operands of '%s' have incompatible types
  '%s' のオペランドは互換性のないタイプがあります
108 operand of '%s' has incompatible type
  '%s' のオペランドは互換性のないタイプがあります
109 void type illegal in expression
 式中の不正な void タイプ
110 pointer to function is not allowed here
 関数へのポインタはここに許可されません
111 unacceptable operand of '%s'
  '%s' の受け付けられないオペランド
112 cannot take address of bit-field
 ビットフィールドのアドレスを取ることができません
113 cannot take address of register %s
 レジスタ %s のアドレスを取ることができません
114 %soperand of '%s' must be lvalue
  '%s' の %soperand は lvalue (左辺値) でなければなりません
115 %soperand of '%s' must be modifiable lvalue
  '%s' の %soperand は修正できる lvalue (左辺値) でなければ
 なりません
116 illegal pointer subtraction
 不正なポインタの引き算
117 bitwise operation on signed value possibly nonportable
 たぶん移植性のない符号付き値でビット毎の演算
118 semantics of '%s' change in ANSI C; use explicit cast
  ANSI C における '%s' のセマンティクスの変更;
 明白な cast (キャスト) を使用してください
119 conversion of '%s' to '%s' is out of range
  '%s' から '%s' の変換は範囲を外れています
120 bitwise operation on signed value nonportable
 移植性のない符号付き値でビット毎の演算
121 negative shift
 負のシフト
122 shift greater than size of object
 オブジェクトのサイズより大きいシフト
123 illegal combination of pointer and integer, op %s
 ポインタと整数の不正な組み合わせ, op %s
124 illegal pointer combination, op %s
 不正なポインタの組み合わせ, op %s
125 ANSI C forbids ordered comparisons of pointers to functions
  ANSI C は関数へのポインタの順序付けられた比較を禁じます
126 incompatible types in conditional
 条件中の互換性のないタイプ
127 '&' before array or function: ignored
 配列または関数の前の '&': 無視されます
128 operands have incompatible pointer types, op %s
 オペランドには互換性のないポインタタイプがあります, op %s
129 expression has null effect
 表には効果がありません
130 enum type mismatch, op %s
 列挙タイプが一致しない, op %s
131 conversion to '%s' may sign-extend incorrectly
  '%s' への変換は符号拡張不正であるかもしれません
132 conversion from '%s' may lose accuracy
  '%s' からの変換は精度を失うかもしれません
133 conversion of pointer to '%s' loses bits
  '%s' へのポインタの変換はビットを失います
134 conversion of pointer to '%s' may lose bits
  '%s' へのポインタの変換はビットを失うかもしれません
135 possible pointer alignment problem
 可能なポインタ整列問題
136 cannot do pointer arithmetic on operand of unknown size
 未知のサイズのオペランドでポインタ演算ができません
137 use of incomplete enum type, op %s
 不完全な列挙タイプの使用, op %s
138 unknown operand size, op %s
 未知のオペランドサイズ, op %s
139 division by 0
  0 の除算
140 modulus by 0
  0 の剰余
141 integer overflow detected, op %s
 検出された整数オーバフロー, op %s
142 floating point overflow detected, op %s
 検出された浮動小数点オーバフロー, op %s
143 cannot take size of incomplete type
 不完全なタイプのサイズを取ることができません
144 cannot take size of function
 関数のサイズを取ることができません
145 cannot take size of bit-field
 ビットフィールドのサイズを取ることができません
146 cannot take size of void
  void のサイズを取ることができません
147 invalid cast expression
 無効のキャスト式
148 improper cast of void expression
  void 式の不適切なキャスト
149 illegal function
 不正な関数
150 argument mismatch: %d arg%s passed, %d expected
 引数不一致: %d arg%s 渡された, %d 期待された
151 void expressions may not be arguments, arg #%d
  void の式は引数でないかもしれない, arg #%d
152 argument cannot have unknown size, arg #%d
 引数は未知のサイズを持つことができません, arg #%d
153 argument has incompatible pointer type, arg #%d
 引数は互換性のなりポインタタイプがあります, arg #%d
154 illegal combination of pointer and integer, arg #%d
 ポインタと整数の不正な組み合わせ, arg #%d
155 argument is incompatible with prototype, arg #%d
 引数はプロトタイプと互換性がありません, arg #%d
156 enum type mismatch, arg #%d
 列挙タイプが不一致, arg #%d
157 ANSI C treats constant as unsigned
  ANSI C は符号なしとして定数を扱います
158 %s may be used before set
  %s は設定される前に使用されるかもしれません
159 assignment in conditional context
 条件文の文脈での代入
160 operator '==' found where '=' was expected
  '=' が予想されるところでオペレータ '==' が見つかりました
161 constant in conditional context
 条件文の文脈での定数
162 comparison of %s with %s, op %s
  %s と %s の比較, op %s
163 a cast does not yield an lvalue
 キャストは lvalue (左辺値) をもたらしません
164 assignment of negative constant to unsigned type
 符号ないタイプへの負の定数の代入
165 constant truncated by assignment
 代入で切り捨てられた定数
166 precision lost in bit-field assignment
 ビットフィールド代入で失われた精度
167 array subscript cannot be negative: %ld
 配列の添字は負であるはずがありません: %ld
168 array subscript cannot be > %d: %ld
 配列の添字は %d より大きいはずがありません: %ld
169 precedence confusion possible: parenthesize!
 優先順位の混乱の可能性: 括弧!
170 first operand must have scalar type, op?:
 最初のオペランドはスカラ型でなければなりません, op?:
171 assignment type mismatch
 代入タイプ不一致
172 too many struct/union initializers
 あまりに多くの構造体/共用体の初期化子
173 too many array initializers
 あまりに多くの配列の初期化子
174 too many initializers
 あまりに多くの初期化子
175 initialisation of an incomplete type
 不完全なタイプの初期化
176 invalid initializer
 無効の初期化子
177 non-constant initializer
 非定数の初期化子
178 initializer does not fit
 初期化子は適合しません
179 cannot initialize struct/union with no named member
 名前のないメンバで構造体/共用体を初期化することができません
180 bit-field initializer does not fit
 ビットフィールド初期化子は適合しません
181 {}-enclosed initializer required
  {} で囲まれた初期化子が必要です
182 incompatible pointer types
 互換性のないポインタタイプ
183 illegal combination of pointer and integer
 ポインタと整数の不正な組み合わせ
184 illegal pointer combination
 不正なポインタの組み合わせ
185 initialisation type mismatch
 初期化タイプの不一致
186 bit-field initialisation is illegal in traditional C
 ビットフィールド初期化は伝統的な C で不正です
187 non-null byte ignored in string initializer
 文字列初期化子で無視された非ヌルバイト
188 no automatic aggregate initialization in traditional C
 伝統的な C でオートマチック集合初期化はありません
189 assignment of struct/union illegal in traditional C
 伝統的な C の不正な構造体/共用体の代入
190 empty array declaration: %s
 空の配列の宣言: %s
191 %s set but not used in function %s
  %s が設定されていますが関数 %s で使用されません
192 %s unused in function %s
  %s が関数 %s で未使用
193 statement not reached
 文に到達しません
194 label %s redefined
 再定義されたラベル %s
195 case not in switch
  switch でないところに case
196 case label affected by conversion
 変換で影響された case ラベル
197 non-constant case expression
 非定数の case 式
198 non-integral case expression
 非整数の case 式
199 duplicate case in switch: %ld
  switch での重複した case: %ld
200 duplicate case in switch: %lu
  switch での重複した case: %lu
201 default outside switch
  switch の外側の default
202 duplicate default in switch
  switch 中に重複した default
203 case label must be of type `int' in traditional C
  case ラベルは伝統的な C でタイプ 'int' でなければなりません
204 controlling expressions must have scalar type
 制御式はスカラ型でなければなりません
205 switch expression must have integral type
  switch 式は整数タイプでなければなりません
206 enumeration value(s) not handled in switch
 列挙型の値は switch で扱われません
207 loop not entered at top
 先端で入れないループ
208 break outside loop or switch
 ループまたは switch の外側の break
209 continue outside loop
 ループの外側の continue
210 enum type mismatch in initialisation
 初期化中の列挙タイプの不一致
211 return value type mismatch
 返り値タイプが不一致
212 cannot return incomplete type
 不完全なタイプを返すことができません
213 void function %s cannot return value
  void 関数 %s は値を返すことができません
214 function %s expects to return value
 関数 %s は値を返すと予想されます
215 function implicitly declared to return int
  int を返すと暗黙に宣言された関数
216 function %s has return (e); and return;
 関数 %s は return (e);と return;があります
217 function %s falls off bottom without returning value
 関数 %s は返り値なしで下部から落ち込みます
218 ANSI C treats constant as unsigned, op %s
  ANSI C は符号なしで定数を扱います, op %s
219 concatenated strings are illegal in traditional C
 連結された文字列は伝統的な C で不正です
220 fallthrough on case statement
  case 文で通り抜け
221 initialisation of unsigned with negative constant
 負の定数による符号なしの初期化
222 conversion of negative constant to unsigned type
 符号なしタイプへの負の定数の変換
223 end-of-loop code not reached
 到達しなかったループコードの終り
224 cannot recover from previous errors
 前のエラーから復旧することができません
225 static function called but not defined: %s()
 静的な関数が呼び出されましたが定義されていません: %s()
226 static variable %s unused
 静的な変数 %s は未使用です
227 const object %s should have initializer
  const オブジェクト %s には初期化子があるべきです
228 function cannot return const or volatile object
 関数は const か volatile オブジェクトを返すことができません
229 questionable conversion of function pointer
 関数ポインタの不確かな変換
230 nonportable character comparison, op %s
 移植性のない文字の比較, op %s
231 argument %s unused in function %s
 関数 %s で未使用の引数 %s
232 label %s unused in function %s
 関数 %s で未使用のラベル %s
233 struct %s never defined
 決して定義されなかった構造体 %s
234 union %s never defined
 決して定義されなかった共用体 %s
235 enum %s never defined
 決して定義されなかった列挙型 %s
236 static function %s unused
 静的な関数 %s は未使用です
237 redeclaration of formal parameter %s
 正式なパラメータ %s の再宣言
238 initialisation of union is illegal in traditional C
 共用体の初期化は伝統的な C で不正です
239 constant argument to NOT
  NOT への定数引数
240 assignment of different structures
 異なった構造体の代入
241 dubious operation on enum, op %s
 列挙型における疑わしい操作, op %s
242 combination of '%s' and '%s', op %s
  '%s' と '%s' の組み合わせ, op %s
243 dubious comparison of enums, op %s
 列挙型の疑わしい比較, op %s
244 illegal structure pointer combination
 不正な構造体のポインタの組み合わせ
245 illegal structure pointer combination, op %s
 不正な構造のポインタの組み合わせ, op %s
246 dubious conversion of enum to '%s'
  '%s' への列挙型の疑わしい変換
247 pointer casts may be troublesome
 ポインタキャストは面倒であるかもしれません
248 floating-point constant out of range
 範囲外の浮動小数点定数
249 syntax error
 構文エラー
250 unknown character \%o
 未知の文字\%o
251 malformed integer constant
 不正な形式の整数定数
252 integer constant out of range
 範囲外の整数定数
253 unterminated character constant
 終了しない文字定数
254 newline in string or char constant
 文字列か文字定数中の改行
255 undefined or invalid # directive
 未定義または無効の # 指示
256 unterminated comment
 終了しないコメント
257 extra characters in lint comment
  lint コメントでの規格外の文字
258 unterminated string constant
 終了しない文字列定数
259 conversion to '%s' due to prototype, arg #%d
 プロトタイプによる '%s' への変換, arg #%d
260 previous declaration of %s
  %s の前の宣言
261 previous definition of %s
  %s の前の定義
262 \" inside character constants undefined in traditional C
 伝統的な C で未定義の文字定数内の\"
263 \? undefined in traditional C
 伝統的な C で未定義の\?
264 \v undefined in traditional C
 伝統的な C で未定義の\v
265 %s C does not support 'long long'
  %s C は 'long long' をサポートしない
266 'long double' is illegal in traditional C
  'long double' は伝統的な C で不正です
267 shift equal to size of object
 オブジェクトのサイズと等しいシフト
268 variable declared inline: %s
 インラインで宣言している変数: %s
269 argument declared inline: %s
 インラインで宣言している引数: %s
270 function prototypes are illegal in traditional C
 関数プロトタイプは伝統的な C で不正です
271 switch expression must be of type `int' in traditional C
  switch 式は伝統的な C でタイプ 'int' でなければなりません
272 empty translation unit
 空の変換単位
273 bit-field type '%s' invalid in ANSI C
  ANSI C で無効のビットフィールドタイプ '%s'
274 ANSI C forbids comparison of %s with %s
  ANSI C は %s と %s の比較を禁止します
275 cast discards 'const' from pointer target type
 キャストはポインタターゲットタイプから 'const' を捨てます
276
277 initialisation of '%s' with '%s'
  '%s' で '%s' の初期化
278 combination of '%s' and '%s', arg #%d
  '%s' と '%s' の組み合わせ, arg #%d
279 combination of '%s' and '%s' in return
  return における '%s' と '%s' の組み合わせ
280 must be outside function: /* %s */
 関数の外側でなければなりません: /* %s */
281 duplicate use of /* %s */
  /* %s */ の重複した使用
282 must precede function definition: /* %s */
 関数定義に先行しなければなりません: /* %s */
283 argument number mismatch with directive: /* %s */
 引数番号は指示で不一致: /* %s */
284 fallthrough on default statement
  default 文で通り抜け
285 prototype declaration
 プロトタイプ宣言
286 function definition is not a prototype
 関数定義はプロトタイプではありません
287 function declaration is not a prototype
 機能宣言はプロトタイプではありません
288 dubious use of /* VARARGS */ with /* %s */
  /* %s */ で /* VARARGS */ の疑わしい使用
289 can't be used together: /* PRINTFLIKE */ /* SCANFLIKE */
 一緒に使用することができません: /* PRINTFLIKE */ /* SCANFLIKE */
290 static function %s declared but not defined
 静的関数 %s が宣言されましたが、定義されていません
291 invalid multibyte character
 無効のマルチバイト文字
292 cannot concatenate wide and regular string literals
 広くて通常の文字列リレラルを連結することができません
293 argument %d must be 'char *' for PRINTFLIKE/SCANFLIKE
 引数 %d は PRINTFLIKE/SCANFLIKE のために 'char *' でなければなりません
294 multi-character character constant
 マルチ文字の文字定数
295 conversion of '%s' to '%s' is out of range, arg #%d
  '%s' から '%s' の変換は範囲外です, arg #%d
296 conversion of negative constant to unsigned type, arg #%d
 符号なしタイプへの負の定数の変換, arg #%d
297 conversion to '%s' may sign-extend incorrectly, arg #%d
  '%s' への変換は不正にサイン拡張されるかもしれません, arg #%d
298 conversion from '%s' may lose accuracy, arg #%d
  '%s' からの変換は精度を失うかもしれません, arg #%d
299 prototype does not match old style definition, arg #%d
 プロトタイプは古いスタイル定義に一致しません, arg #%d
300 old style definition
 古いスタイル定義
301 array of incomplete type
 不完全なタイプの配列
302 %s returns pointer to automatic object
  %s はオートマチックオブジェクトへのポインタを返します
303 ANSI C forbids conversion of %s to %s
  ANSI C は %s から %s の変換を禁止します
304 ANSI C forbids conversion of %s to %s, arg #%d
  ANSI C は %s から %s の変換を禁止します, arg #%d
305 ANSI C forbids conversion of %s to %s, op %s
  ANSI C は %s から %s の変換を禁止します, op %s
306 constant truncated by conversion, op %s
 変換で先端を切り捨てられた定数, op %s
307 static variable %s set but not used
 静的な変数 %s を設定しましたが使用されていません
308
309 extra bits set to 0 in conversion of '%s' to '%s', op %s
  '%s' から '%s' の変換で余分なビットは 0 に設定, op %s
310 symbol renaming can't be used on function arguments
 シンボルの改名は関数引数で使用することができません
311 symbol renaming can't be used on automatic variables
 シンボルの改名はオートマチック変数で使用することができません
312 %s C does not support // comments
  %s C は // コメントをサポートしません
July 5, 2000 FreeBSD