|VM_MAP_REMOVE(9)||FreeBSD Kernel Developer's Manual||VM_MAP_REMOVE(9)|
NAMEvm_map_remove — remove a virtual address range from a map
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/vm_map.h>
vm_map_remove( vm_map_t map, vm_offset_t start, vm_offset_t end);
DESCRIPTIONThe vm_map_remove() function removes the given address range bounded by start and end from the target map.
IMPLEMENTATION NOTESThis is the exported form of vm_map_delete(9) which may be called by consumers of the VM subsystem.
The function calls vm_map_lock(9) to hold a lock on map for the duration of the function call.
RETURN VALUESThe vm_map_remove() always returns KERN_SUCCESS.
AUTHORSThis manual page was written by <email@example.com>.
|July 19, 2003||FreeBSD|