|VM_MAP_FINDSPACE(9)||FreeBSD Kernel Developer's Manual||VM_MAP_FINDSPACE(9)|
NAMEvm_map_findspace — find a free region within a map
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/vm_map.h>
vm_map_findspace( vm_map_t map, vm_offset_t start, vm_size_t length, vm_offset_t *addr);
DESCRIPTIONThe vm_map_findspace() function attempts to find a region with sufficient space in the map for an object of size length at the address addr.
IMPLEMENTATION NOTESIt is the caller's responsibility to obtain a lock on the map using vm_map_lock(9) before calling this function.
This routine may call pmap_growkernel(9) to grow the kernel's address space, if and only if the mapping is being made within the kernel address space, and if insufficient space remains in the kernel_map.
RETURN VALUESThe vm_map_findspace() function returns the value 0 if successful, and *addr will contain the first virtual address in the found region; otherwise, the value 1 is returned.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 19, 2003||FreeBSD|