|VM_MAP_DELETE(9)||FreeBSD Kernel Developer's Manual||VM_MAP_DELETE(9)|
NAMEvm_map_delete — deallocate an address range from a map
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/vm_map.h>
vm_map_delete( vm_map_t map, vm_offset_t start, vm_offset_t end);
DESCRIPTIONThe vm_map_delete() function deallocates the address range bounded by start and end from the map.
IMPLEMENTATION NOTESThis function is for FreeBSD VM internal use only. The vm_map_remove(9) function should be called by FreeBSD VM consumers instead.
RETURN VALUESThe vm_map_delete() function always returns KERN_SUCCESS.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 19, 2003||FreeBSD|