|THREAD_EXIT(9)||FreeBSD Kernel Developer's Manual||THREAD_EXIT(9)|
NAMEthread_exit — abandon current thread context
DESCRIPTIONThe thread_exit() function implements the machine independent prelude to a thread shutdown. It will not return, and will result in a call to mi_switch(9) to schedule some other thread.
thread_exit() arranges to free all the resources of the thread, specifically the kernel stack.
To protect the runqueue(9), thread_exit() must be called with the sched_lock mutex held.
|July 5, 2002||FreeBSD|