EN JA
PMAP_QENTER(9)
PMAP_QENTER(9) FreeBSD Kernel Developer's Manual PMAP_QENTER(9)

NAME

pmap_qenter, pmap_qremovemanage temporary kernel space mappings

SYNOPSIS

#include < sys/param.h>
#include < vm/vm.h>
#include < vm/pmap.h>

void
pmap_qenter( vm_offset_t sva, vm_page_t *m, int count);

void
pmap_qremove( vm_offset_t sva, int count);

DESCRIPTION

The pmap_qenter() function accepts a linear array of count pointers to wired pages *m, and enters each of these pages into the kernel virtual address (KVA) space, beginning at the address sva.

The pmap_qremove() function tears out a mapping from the kernel virtual address space, beginning at sva and for count pages.

IMPLEMENTATION NOTES

The pmap_qenter() function is intended for temporary mappings that do not require page modification or reference counting. Old mappings are simply overwritten. The pages must be wired into physical memory.

The corresponding pmap_qremove() function is intended to remove such temporary mappings.

SEE ALSO

pmap(9)

AUTHORS

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 21, 2003 FreeBSD