|PMAP_QENTER(9)||FreeBSD Kernel Developer's Manual||PMAP_QENTER(9)|
NAMEpmap_qenter, pmap_qremove — manage temporary kernel space mappings
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/pmap.h>
pmap_qenter( vm_offset_t sva, vm_page_t *m, int count);
pmap_qremove( vm_offset_t sva, int count);
DESCRIPTIONThe pmap_qenter() function accepts a linear array of count pointers to wired pages *m, and enters each of these pages into the kernel virtual address (KVA) space, beginning at the address sva.
The pmap_qremove() function tears out a mapping from the kernel virtual address space, beginning at sva and for count pages.
IMPLEMENTATION NOTESThe pmap_qenter() function is intended for temporary mappings that do not require page modification or reference counting. Old mappings are simply overwritten. The pages must be wired into physical memory.
The corresponding pmap_qremove() function is intended to remove such temporary mappings.
AUTHORSThis manual page was written by <firstname.lastname@example.org>.
|July 21, 2003||FreeBSD|