|PMAP_PAGE_EXISTS_QUICK(9)||FreeBSD Kernel Developer's Manual||PMAP_PAGE_EXISTS_QUICK(9)|
NAMEpmap_page_exists_quick — determine if a page exists in a physical map
SYNOPSIS#include < sys/param.h>
#include < vm/vm.h>
#include < vm/pmap.h>
pmap_page_exists_quick( pmap_t pmap, vm_page_t m);
DESCRIPTIONThe pmap_page_exists_quick() function is used to quickly determine if the page m exists in the physical map pmap. It is typically called from the VM paging code.
IMPLEMENTATION NOTESThe PV count used above may be changed upwards or downwards in future; it is only necessary that TRUE be returned for a small subset of pmaps for proper page aging.
RETURN VALUESThe pmap_page_exists_quick() returns TRUE only if the PV entry for the physical map pmap is one of the first 16 PVs linked from the page m.
AUTHORSThis manual page was written by <email@example.com>.
|July 21, 2003||FreeBSD|