|PANIC(9)||FreeBSD Kernel Developer's Manual||PANIC(9)|
NAMEpanic — bring down system on fatal error
DESCRIPTIONThe panic() function terminates the running system. The message fmt is a printf(3) style format string. The message is printed to the console and the location panicstr is set to the address of the message text for retrieval from the OS core dump.
If the kernel debugger is installed control is passed to it, otherwise an attempt to save a core dump of the OS to a configured dump device is made.
If panic() is called twice (from the disk sync routines, for example) the system is rebooted without syncing the disks.
RETURN VALUESThe panic() function does not return.
|August 11, 1995||FreeBSD|