|DEVICE_SET_DESC(9)||FreeBSD Kernel Developer's Manual||DEVICE_SET_DESC(9)|
NAMEdevice_set_desc, device_set_desc_copy, device_get_desc — access the description of a device
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
device_set_desc( device_t dev, const char *desc);
device_set_desc_copy( device_t dev, const char *desc);
const char *
device_get_desc( device_t dev);
DESCRIPTIONManipulate the verbose description of a device. This description (if present) is printed as part of the message when it is attached during autoconfiguration. The variation device_set_desc_copy() is used to set the description if the string passed is a temporary buffer which will be overwritten. In this case, the system will copy the string, otherwise the pointer passed will be used directly.
AUTHORSThis manual page was written by .
|June 16, 1998||FreeBSD|