|DEVICE_GET_CHILDREN(9)||FreeBSD Kernel Developer's Manual||DEVICE_GET_CHILDREN(9)|
NAMEdevice_get_children — get a list of devices connected to a device
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
device_get_children( device_t dev, device_t **devlistp, int *devcountp);
DESCRIPTIONRetrieve a list of all device instances currently connected to dev and return the list in *devlistp and the count in *devcountp. The memory allocated for the list should be freed using free( *devlistp, M_TEMP). devlistp and devcountp are not changed when an error is returned.
RETURN VALUESZero is returned on success, otherwise an appropriate error is returned.
AUTHORSThis manual page was written by .
|August 23, 2008||FreeBSD|