|DEVICE_FIND_CHILD(9)||FreeBSD Kernel Developer's Manual||DEVICE_FIND_CHILD(9)|
NAMEdevice_find_child — search for a child of a device
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
device_find_child( device_t dev, const char *classname, int unit);
DESCRIPTIONThis function looks for a specific child of dev with the given classname and unit. If unit is -1, it returns the first child of dev with a matching classname (that is, the one with the lowest unit).
RETURN VALUESIf it exists, the child device is returned, otherwise NULL.
AUTHORSThis manual page was written by .
|February 8, 2005||FreeBSD|