|DEVICE_ENABLE(9)||FreeBSD Kernel Developer's Manual||DEVICE_ENABLE(9)|
NAMEdevice_enable, device_disable, device_is_enabled — manipulate device enabled flag
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
device_enable( device_t dev);
device_disable( device_t dev);
device_is_enabled( device_t dev);
DESCRIPTIONEach device has an enabled flag associated with it. A device is enabled by default when it is created but may be disabled (for instance to prevent a destructive or time consuming probe attempt). To disable a device, call device_disable(), to re-enable it, call device_enable() and to test to see if a device is enabled, call device_is_enabled().
AUTHORSThis manual page was written by .
|June 16, 1998||FreeBSD|