|BUS_SET_RESOURCE(9)||FreeBSD Kernel Developer's Manual||BUS_SET_RESOURCE(9)|
NAMEbus_set_resource — associate a definite resource with a given resource ID
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
bus_set_resource( device_t dev, int type, int rid, u_long start, u_long count);
DESCRIPTIONThe bus_set_resource() function sets the start address of the resource type, rid pair to be count long. Typically, client drivers do not use this interface. Bus drivers, however, often use it to set up the resources a client driver uses.
The arguments are as follows:
- The device to set the resource on.
The type of resource you want to allocate. It is one of:
- for IRQs
- for ISA DMA lines
- for I/O ports
- for I/O memory
- A bus-specific handle that identifies the resource being allocated.
- The start address of this resource.
- The length of the resource. For example, the size of the memory in bytes.
RETURN VALUESZero is returned on success, otherwise an error is returned.
AUTHORSThis manual page was written by <imp@FreeBSD.org>.
|March 29, 2003||FreeBSD|