|BUS_CHILD_PRESENT(9)||FreeBSD Kernel Developer's Manual||BUS_CHILD_PRESENT(9)|
NAMEbus_child_present — ask the bus driver to see if this device is still really present
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
bus_child_present( device_t dev);
DESCRIPTIONThe bus_child_present() function requests that the parent device driver of dev check to see if the hardware represented by dev is still physically accessible at this time. While the notion of accessible varies from bus to bus, generally hardware that is not accessible cannot be accessed via the bus_space*() methods that would otherwise be used to access the device.
This does not ask the question “does this device have children?” which can better be answered by device_get_children(9).
RETURN VALUESA zero return value indicates that the device is not present in the system. A non-zero return value indicates that the device is present in the system, or that the state of the device cannot be determined.
EXAMPLESThis is some example code. It only calls stop when the dc(4) device is actually present.
device_t dev; dc_softc *sc; sc = device_get_softc(dev); if (bus_child_present(dev)) dc_stop(sc);
AUTHORSThis manual page was written by <imp@FreeBSD.org>.
|March 27, 2003||FreeBSD|