|VOP_STRATEGY(9)||FreeBSD Kernel Developer's Manual||VOP_STRATEGY(9)|
NAMEVOP_STRATEGY — read or write a file system buffer
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_STRATEGY( struct vnode *vp, struct buf *bp);
DESCRIPTIONThe arguments are:
- The vnode that the buffer is for.
- The buffer to be read or written.
This call either reads or writes data from a file, depending on the value of bp->b_io.bio_cmd.
The call may block.
RETURN VALUESAlways zero. Errors should be signalled by setting BIO_ERROR on b_ioflags field in struct buf, and setting b_error to the appropriate errno value.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|