|VOP_REMOVE(9)||FreeBSD Kernel Developer's Manual||VOP_REMOVE(9)|
NAMEVOP_REMOVE, VOP_RMDIR — remove a file or directory
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_REMOVE( struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
VOP_RMDIR( struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
DESCRIPTIONThese entry points remove files and directories respectively.
The arguments are:
- The vnode of the directory.
- The vnode of the file to be removed.
- Pathname information about the file.
LOCKSBoth dvp and vp should be locked on entry and remain locked on return.
RETURN VALUESZero is returned on success, otherwise an error code is returned.
- [ EPERM]
- The file is immutable.
- [ ENOTEMPTY]
- An attempt was made to remove a directory which is not empty.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|