|VOP_RENAME(9)||FreeBSD Kernel Developer's Manual||VOP_RENAME(9)|
NAMEVOP_RENAME — rename a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_RENAME( struct vnode *fdvp, struct vnode *fvp, struct componentname *fcnp, struct vnode *tdvp, struct vnode *tvp, struct componentname *tcnp);
DESCRIPTIONThis renames a file and possibly changes its parent directory. If the destination object exists, it will be removed first.
Its arguments are:
- The vnode of the old parent directory.
- The vnode of the file to be renamed.
- Pathname information about the file's current name.
- The vnode of the new parent directory.
- The vnode of the target file (if it exists).
- Pathname information about the file's new name.
LOCKSThe source directory and file are unlocked but are expected to have their ref count bumped on entry. The VOP routine is expected to vrele(9) both prior to returning.
The destination directory and file are locked as well as having their ref count bumped. The VOP routine is expected to vput(9) both prior to returning.
- [ EPERM]
- The file is immutable.
- [ EXDEV]
- It is not possible to rename a file between different file systems.
- [ EINVAL]
- An attempt was made to rename . or .., or to perform an operation which would break the directory tree structure.
- [ ENOTDIR]
- An attempt was made to rename a directory to a file or vice versa.
- [ ENOTEMPTY]
- An attempt was made to remove a directory which is not empty.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|