|VOP_RDWR(9)||FreeBSD Kernel Developer's Manual||VOP_RDWR(9)|
NAMEVOP_READ, VOP_WRITE — read or write a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
#include < sys/uio.h>
VOP_READ( struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred);
VOP_WRITE( struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred);
DESCRIPTIONThese entry points read or write the contents of a file
The arguments are:
- The vnode of the file.
- The location of the data to be read or written.
- Various flags.
- The credentials of the caller.
The ioflag argument is used to give directives and hints to the file system. When attempting a read, the high 16 bits are used to provide a read-ahead hint (in units of file system blocks) that the file system should attempt. The low 16 bits are a bit mask which can contain the following flags:
- Do I/O as atomic unit.
- Append write to end.
- Do I/O synchronously.
- Underlying node already locked.
- FNDELAY flag set in file table.
- Data already in VMIO space.
LOCKSThe file should be locked on entry and will still be locked on exit.
RETURN VALUESZero is returned on success, otherwise an error code is returned.
- [ EFBIG]
- An attempt was made to write a file that exceeds the process's file size limit or the maximum file size.
- [ ENOSPC]
- The file system is full.
- [ EPERM]
- An append-only flag is set on the file, but the caller is attempting to write before the current end of file.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|