|VOP_OPEN(9)||FreeBSD Kernel Developer's Manual||VOP_OPEN(9)|
NAMEVOP_OPEN, VOP_CLOSE — open or close a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_OPEN( struct vnode *vp, int mode, struct ucred *cred, struct thread *td, struct file *fp);
VOP_CLOSE( struct vnode *vp, int mode, struct ucred *cred, struct thread *td);
DESCRIPTIONThe VOP_OPEN() entry point is called before a file is accessed by a process and the VOP_CLOSE() entry point is called after a file is finished with by the process.
The arguments are:
- The vnode of the file.
- The access mode required by the calling process.
- The caller's credentials.
- The thread which is accessing the file.
- The file being opened.
Pointer to the file fp is useful for file systems which require such information, e.g., fdescfs(5). Use ‘
NULL’ as fp argument to VOP_OPEN() for in-kernel opens.
The access mode is a set of flags, including FREAD, FWRITE, O_NONBLOCK, O_APPEND.
LOCKSVOP_OPEN() expects vp to be locked on entry and will leave it locked on return.
VOP_CLOSE() expects at least a reference to be associated with the vnode and does not care whether the vnode is locked or not. The lock and reference state is left unchanged on return. Note that vn_close expects an unlocked, referenced vnode and will dereference the vnode prior to returning.
RETURN VALUESZero is returned on success, otherwise an error code is returned.
AUTHORSThis manual page was written by .
|December 2, 2009||FreeBSD|