|VOP_LINK(9)||FreeBSD Kernel Developer's Manual||VOP_LINK(9)|
NAMEVOP_LINK — create a new name for a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_LINK( struct vnode *dvp, struct vnode *vp, struct componentname *cnp);
DESCRIPTIONThis links a new name in the specified directory to an existing file.
Its arguments are:
- The vnode of the directory.
- The vnode of the file to be linked.
- Pathname information about the file.
The pathname info should not be released on exit because it is done by the caller. The directory and file vnodes should not be released on exit.
LOCKSVOP_LINK() expects the directory and file vnodes to be locked on entry and will leave the vnodes locked on return.
RETURN VALUESZero is returned if the file was linked successfully, otherwise an error is returned.
- [ EMLINK]
- The file has too many links.
- [ EPERM]
- The file is immutable.
- [ EXDEV]
- A hard link is not possible between different file systems.
AUTHORSThis manual page was originally written by .
|July 24, 1996||FreeBSD|