|VOP_GETACL(9)||FreeBSD Kernel Developer's Manual||VOP_GETACL(9)|
NAMEVOP_GETACL — retrieve access control list for a vnode
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
#include < sys/acl.h>
VOP_GETACL( struct vnode *vp, acl_type_t type, struct acl *aclp, struct ucred *cred, struct thread *td);
DESCRIPTIONThis vnode call may be used to retrieve the access control list (ACL) from a file or directory.
Its arguments are:
- The vnode of the file or directory.
- The type of ACL to retrieve.
- A pointer to an ACL structure to receive the ACL data.
- The user credentials to use in authorizing the request.
- The thread requesting the ACL.
The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize ACL retrieval that the active process might not be permitted to do.
The vnode ACL interface defines the syntax, and not semantics, of file and directory ACL interfaces. More information about ACL management in kernel may be found in acl(9).
LOCKSThe vnode will be locked on entry and should remain locked on return.
RETURN VALUESIf the aclp pointer will point to a valid ACL, then zero is returned. Otherwise, an appropriate error code is returned.
- [ EINVAL]
- The ACL type passed is invalid for this vnode.
- [ EACCES]
- The caller does not have the appropriate privilege.
- [ ENOMEM]
- Sufficient memory is not available to fulfill the request.
- [ EOPNOTSUPP]
- The file system does not support VOP_GETACL().
AUTHORSThis manual page was written by .
|December 23, 1999||FreeBSD|