|VOP_FSYNC(9)||FreeBSD Kernel Developer's Manual||VOP_FSYNC(9)|
NAMEVOP_FSYNC — flush file system buffers for a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_FSYNC( struct vnode *vp, int waitfor, struct thread *td);
DESCRIPTIONThis call flushes any dirty file system buffers for the file. It is used to implement the sync(2) and fsync(2) system calls.
Its arguments are:
- The vnode of the file.
Whether the function should wait for I/O to complete. Possible values are:
- Synchronously wait for I/O to complete.
- Start all I/O, but do not wait for it.
- Push data not written by file system syncer.
- The calling thread.
LOCKSThe file should be locked on entry.
RETURN VALUESZero is returned if the call is successful, otherwise an appropriate error code is returned.
- [ ENOSPC]
- The file system is full.
- [ EDQUOT]
- Quota exceeded.
AUTHORSThis manual page was written by .
|July 24, 1996||FreeBSD|