|VOP_ALLOCATE(9)||FreeBSD Kernel Developer's Manual||VOP_ALLOCATE(9)|
NAMEVOP_ALLOCATE — allocate storage for a file
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_ALLOCATE( struct vnode *vp, off_t *offset, off_t *len);
DESCRIPTIONThis call allocates storage for a range of offsets in a file. It is used to implement the posix_fallocate system call.
Its arguments are:
- The vnode of the file.
- The start of the range to allocate storage for in the file.
- The length of the range to allocate storage for in the file.
The offset and len arguments are updated to reflect the portion of the range that still needs to be allocated on return. A partial allocation is considered a successful operation. The file's contents are not changed.
LOCKSThe file should be exclusively locked on entry and will still be locked on exit.
RETURN VALUESZero is returned if the call is successful, otherwise an appropriate error code is returned.
- [ EFBIG]
- An attempt was made to write a file that exceeds the process's file size limit or the maximum file size.
- [ ENOSPC]
- The file system is full.
- [ EPERM]
- An append-only flag is set on the file, but the caller is attempting to write before the current end of file.
|October 3, 2013||FreeBSD|