|VOP_ADVLOCK(9)||FreeBSD Kernel Developer's Manual||VOP_ADVLOCK(9)|
NAMEVOP_ADVLOCK — advisory record locking
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
#include < sys/fcntl.h>
#include < sys/lockf.h>
VOP_ADVLOCK( struct vnode *vp, caddr_t id, int op, struct flock *fl, int flags);
DESCRIPTIONThe arguments are:
- The vnode being manipulated.
- The id token which is changing the lock.
- The operation to perform (see fcntl(2)).
- Description of the lock.
One of more of the following:
- Shared or read lock.
- Exclusive or write lock.
- Wait until lock is granted.
- Use flock(2) semantics for lock.
- Use POSIX semantics for lock.
This entry point manipulates advisory record locks on the file. Most file systems delegate the work for this call to lf_advlock().
RETURN VALUESZero is returned on success, otherwise an error is returned.
AUTHORSThis manual page was written by .
|June 30, 1999||FreeBSD|