|VOP_ACCESS(9)||FreeBSD Kernel Developer's Manual||VOP_ACCESS(9)|
NAMEVOP_ACCESS, VOP_ACCESSX — check access permissions of a file or Unix domain socket
SYNOPSIS#include < sys/param.h>
#include < sys/vnode.h>
VOP_ACCESS( struct vnode *vp, accmode_t accmode, struct ucred *cred, struct thread *td);
VOP_ACCESSX( struct vnode *vp, accmode_t accmode, struct ucred *cred, struct thread *td);
DESCRIPTIONThis entry point checks the access permissions of the file against the given credentials.
Its arguments are:
- The vnode of the file to check.
- The type of access required.
- The user credentials to check.
- The thread which is checking.
The accmode is a mask which can contain flags described in <sys/vnode.h>, e.g. VREAD, VWRITE or VEXEC. For VOP_ACCESS(), the only flags that may be set in accmode are VEXEC, VWRITE, VREAD, VADMIN and VAPPEND. To check for other flags, one has to use VOP_ACCESSX() instead.
LOCKSThe vnode will be locked on entry and should remain locked on return.
RETURN VALUESIf the file is accessible in the specified way, then zero is returned, otherwise an appropriate error code is returned.
- [ EPERM]
- An attempt was made to change an immutable file.
- [ EACCES]
- The permission bits the file mode or the ACL do not permit the requested access.
AUTHORSThis manual page was written by .
|September 18, 2009||FreeBSD|