|VFS_STATFS(9)||FreeBSD Kernel Developer's Manual||VFS_STATFS(9)|
NAMEVFS_STATFS — return file system status
SYNOPSIS#include < sys/param.h>
#include < sys/mount.h>
#include < sys/vnode.h>
VFS_STATFS( struct mount *mp, struct statfs *sbp);
DESCRIPTIONThe VFS_STATFS() macro returns various pieces of information about the file system, including recommended I/O sizes, free space, free inodes, etc.
The arguments it expects are:
- The file system.
- A statfs structure, as defined by < sys/mount.h>, into which information is placed about the file system.
The fields of struct statfs related to the file system are as follows:
- Type of file system.
- A copy of mount exported flags.
- Fragment size.
- Optimal transfer block size.
- The total number of data blocks in the file system.
- The number of free blocks in the file system.
- The number of free blocks available to non-superuser processes.
- The total number of file nodes in the file system.
- The number of free nodes available to non-superuser processes.
- The number of synchronous writes since the file system was mounted.
- The number of asynchronous writes since the file system was mounted.
- The number of synchronous reads since the file system was mounted.
- The number of asynchronous reads since the file system was mounted.
- The maximum file name length for this file system.
- The user ID of the user that mounted the file system.
- Unique file system ID.
- The file system type name; a string of at most MFSNAMELEN bytes.
- The device name the file system was mounted from; a string of at most MNAMELEN bytes.
- The name of the directory on which the file system is mounted; a string of at most MNAMELEN bytes.
AUTHORSThis manual page was written by .
|May 23, 2009||FreeBSD|