|VFS_MOUNT(9)||FreeBSD Kernel Developer's Manual||VFS_MOUNT(9)|
NAMEVFS_MOUNT — mount a file system
SYNOPSIS#include < sys/param.h>
#include < sys/mount.h>
#include < sys/vnode.h>
VFS_MOUNT( struct mount *mp);
DESCRIPTIONThe VFS_MOUNT() macro mounts a file system into the system's namespace or updates the attributes of an already mounted file system.
The arguments it expects are:
- Structure representing the file system.
The VFS_MOUNT() macro is called both to mount new file systems and to change the attributes of an existing file system. If the MNT_UPDATE flag is set in mp->mnt_flag then the file system should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only file system to read-write. It is also used by mountd(8) to update the NFS export information for the file system.
If the MNT_UPDATE flag is not specified, then this is a newly mounted file system. The file system code should allocate and initialize any private data needed to represent the file system (it can use the mp->mnt_data field to store this information).
AUTHORSThis manual page was written by .
|May 23, 2009||FreeBSD|