|NAMEI(9)||FreeBSD Kernel Developer's Manual||NAMEI(9)|
NAMEnamei, NDINIT, NDFREE, NDHASGIANT — pathname translation and lookup operations
SYNOPSIS#include < sys/param.h>
#include < sys/fcntl.h>
#include < sys/namei.h>
namei( struct nameidata *ndp);
NDINIT( struct nameidata *ndp, u_long op, u_long flags, enum uio_seg segflg, const char *namep, struct thread *td);
NDFREE( struct nameidata *ndp, const uint flags);
NDHASGIANT( struct nameidata *ndp);
DESCRIPTIONThe namei facility allows the client to perform pathname translation and lookup operations. The namei functions will increment the reference count for the vnode in question. The reference count has to be decremented after use of the vnode, by using either vrele(9) or vput(9), depending on whether the LOCKLEAF flag was specified or not. If the Giant lock is required, namei will acquire it if the caller indicates it is MPSAFE, in which case the caller must later release Giant based on the results of NDHASGIANT().
The NDINIT() function is used to initialize namei components. It takes the following arguments:
- The struct nameidata to initialize.
- The operation which namei() will perform. The following operations are valid: LOOKUP, CREATE, DELETE, and RENAME. The latter three are just setup for those effects; just calling namei() will not result in VOP_RENAME() being called.
- Operation flags. Several of these can be effective at the same time.
- UIO segment indicator. This indicates if the name of the object is in userspace ( UIO_USERSPACE) or in the kernel address space ( UIO_SYSSPACE).
- Pointer to the component's pathname buffer (the file or directory name that will be looked up).
- The thread context to use for namei operations and locks.
NAMEI OPERATION FLAGSThe namei() function takes the following set of “operation flags” that influence its operation:
- Lock vnode on return. This is a full lock of the vnode; the VOP_UNLOCK(9) should be used to release the lock (or vput(9) which is equivalent to calling VOP_UNLOCK(9) followed by vrele(9), all in one).
- This flag lets the namei() function return the parent (directory) vnode, ni_dvp in locked state, unless it is identical to ni_vp, in which case ni_dvp is not locked per se (but may be locked due to LOCKLEAF). If a lock is enforced, it should be released using vput(9) or VOP_UNLOCK(9) and vrele(9).
- This flag allows the namei() function to return the parent (directory) vnode in an unlocked state. The parent vnode must be released separately by using vrele(9).
- Avoid namei() creating this entry in the namecache if it is not already present. Normally, namei() will add entries to the name cache if they are not already there.
- With this flag, namei() will follow the symbolic link if the last part of the path supplied is a symbolic link (i.e., it will return a vnode for whatever the link points at, instead for the link itself).
- Do not follow symbolic links (pseudo). This flag is not looked for by the actual code, which looks for FOLLOW. NOFOLLOW is used to indicate to the source code reader that symlinks are intentionally not followed.
- Do not free the pathname buffer at the end of the namei() invocation; instead, free it later in NDFREE() so that the caller may access the pathname buffer. See below for details.
- Retain an additional reference to the parent directory; do not free the pathname buffer. See below for details.
ALLOCATED ELEMENTSThe nameidata structure is composed of the following fields:
In the normal case, this is either the current directory or the root. It is the current directory if the name passed in does not start with ‘
/’ and we have not gone through any symlinks with an absolute path, and the root otherwise.
In this case, it is only used by lookup(), and should not be considered valid after a call to namei(). If SAVESTART is set, this is set to the same as ni_dvp, with an extra vref(9). To block NDFREE() from releasing ni_startdir, the NDF_NO_STARTDIR_RELE can be set.
- Vnode pointer to directory of the object on which lookup is performed. This is available on successful return if LOCKPARENT or WANTPARENT is set. It is locked if LOCKPARENT is set. Freeing this in NDFREE() can be inhibited by NDF_NO_DVP_RELE, NDF_NO_DVP_PUT, or NDF_NO_DVP_UNLOCK (with the obvious effects).
Vnode pointer to the resulting object,
NULL otherwise. The
v_usecount field of this vnode is incremented. If
LOCKLEAF is set, it is also locked.
Freeing this in NDFREE() can be inhibited by NDF_NO_VP_RELE, NDF_NO_VP_PUT, or NDF_NO_VP_UNLOCK (with the obvious effects).
The pathname buffer contains the location of the file or directory that will be used by the
namei operations. It is managed by the
uma(9) zone allocation interface. If the
SAVENAME flag is set, then the pathname buffer is available after calling the
To only deallocate resources used by the pathname buffer, ni_cnd.cn_pnbuf, then NDF_ONLY_PNBUF flag can be passed to the NDFREE() function. To keep the pathname buffer intact, the NDF_NO_FREE_PNBUF flag can be passed to the NDFREE() function.
RETURN VALUESIf successful, namei() will return 0, otherwise it will return an error.
ERRORSErrors which namei() may return:
- [ ENOTDIR]
- A component of the specified pathname is not a directory when a directory is expected.
- [ ENAMETOOLONG]
- A component of a pathname exceeded 255 characters, or an entire pathname exceeded 1023 characters.
- [ ENOENT]
- A component of the specified pathname does not exist, or the pathname is an empty string.
- [ EACCES]
- An attempt is made to access a file in a way forbidden by its file access permissions.
- [ ELOOP]
- Too many symbolic links were encountered in translating the pathname.
- [ EISDIR]
- An attempt is made to open a directory with write mode specified.
- [ EINVAL]
The last component of the pathname specified for a
RENAME operation is ‘
- [ EROFS]
- An attempt is made to modify a file or directory on a read-only file system.
AUTHORSThis manual page was written by <eivind@FreeBSD.org> and later significantly revised by <hmp@FreeBSD.org>.
BUGSThe LOCKPARENT flag does not always result in the parent vnode being locked. This results in complications when the LOCKPARENT is used. In order to solve this for the cases where both LOCKPARENT and LOCKLEAF are used, it is necessary to resort to recursive locking.
Non-MPSAFE file systems exist, requiring callers to conditionally unlock Giant.
|March 1, 2012||FreeBSD|