|| FreeBSD Kernel Developer's Manual
detach a device
Detach a device. This can be called if the user is replacing the driver software or if a device is about to be physically removed from the system (e.g. for
The method should deallocate any system resources allocated during the DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e., disable interrupts etc.)
RETURN VALUES Zero is returned on success, otherwise an appropriate error is returned.
AUTHORS This manual page was written by