|BUS_CHILD_DELETED(9)||FreeBSD Kernel Developer's Manual||BUS_CHILD_DELETED(9)|
NAMEBUS_CHILD_DELETED — notify a bus device that a child is being deleted
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
BUS_CHILD_DELETED( device_t dev, device_t child);
DESCRIPTIONThe BUS_CHILD_DELETED() method is invoked by the new-bus framework when a device is deleted. A bus driver can provide an implementation of this method to release bus-specific resources associated with a device such as instance variables.
HISTORYThe BUS_CHILD_DELETED() method first appeared in FreeBSD 10.0.
|August 21, 2012||FreeBSD|