|BUS_ADD_CHILD(9)||FreeBSD Kernel Developer's Manual||BUS_ADD_CHILD(9)|
NAMEBUS_ADD_CHILD — add a device node to the tree with a given priority
SYNOPSIS#include < sys/param.h>
#include < sys/bus.h>
BUS_ADD_CHILD( device_t dev, int order, const char *name, int unit);
DESCRIPTIONThe BUS_ADD_CHILD() method is used by the driver identify routine to add devices to the tree. Please see device_add_child(9) for more details. The interface is the same as device_add_child(9) however, the bus' BUS_ADD_CHILD() is called.
Busses implementing BUS_ADD_CHILD() should insert the device into the tree using device_add_child(9) before adding things such as their own ivars and resource lists to the device.
RETURN VALUESThe BUS_ADD_CHILD() method returns device_t added to the tree, or NULL.
AUTHORSThis manual page was written by .
|May 13, 2004||FreeBSD|