EN JA
BUF_ISLOCKED(9)
BUF_ISLOCKED(9) FreeBSD Kernel Developer's Manual BUF_ISLOCKED(9)

NAME

BUF_ISLOCKEDreturns the state of the lock linked to the buffer

SYNOPSIS

#include < sys/param.h>
#include < sys/systm.h>
#include < sys/uio.h>
#include < sys/bio.h>
#include < sys/buf.h>

int
BUF_ISLOCKED( struct buf *bp);

DESCRIPTION

The BUF_ISLOCKED() function returns the status of the lock linked to the buffer in relation to curthread.

It can return:

LK_EXCLUSIVE
An exclusive lock is held by curthread.
LK_EXCLOTHER
An exclusive lock is held by someone other than curthread.
LK_SHARED
A shared lock is held.
0
The lock is not held by anyone.

AUTHORS

This manual page was written by Attilio Rao <attilio@FreeBSD.org>.
January 22, 2008 FreeBSD