|BUF_ISLOCKED(9)||FreeBSD Kernel Developer's Manual||BUF_ISLOCKED(9)|
NAMEBUF_ISLOCKED — returns the state of the lock linked to the buffer
SYNOPSIS#include < sys/param.h>
#include < sys/systm.h>
#include < sys/uio.h>
#include < sys/bio.h>
#include < sys/buf.h>
BUF_ISLOCKED( struct buf *bp);
DESCRIPTIONThe BUF_ISLOCKED() function returns the status of the lock linked to the buffer in relation to curthread.
It can return:
- An exclusive lock is held by curthread.
- An exclusive lock is held by someone other than curthread.
- A shared lock is held.
- The lock is not held by anyone.
AUTHORSThis manual page was written by <attilio@FreeBSD.org>.
|January 22, 2008||FreeBSD|