|WLANDEBUG(8)||FreeBSD System Manager's Manual||WLANDEBUG(8)|
NAMEwlandebug — set/query 802.11 wireless debugging messages
|wlandebug||[ -d | -i ifnet][ -flag|+flag ...]|
DESCRIPTIONThe wlandebug command is a tool for enabling and disabling debugging messages in the wlan(4) module. Running wlandebug without any options will display the current messages enabled for the specified network interface (by default, ``ath0'). The default debugging level for new interfaces can be set by specifying the -d option. When run as the super-user wlandebug can be used to enable and/or disable debugging messages.
To enable debugging messages of a certain type use +type; to disable such messages use -type. Multiple messages can be enabled and disabled with a single command.
Messages are organized in the following groups:
- general debugging facilities; equivalent to setting the debug parameter with ifconfig(8).
- dump packet contents on transmit and receive.
- crypto-related work.
- errors encountered during input handling.
- extended rate set handling (for 802.11g).
- information element processing in 802.11 management frames.
- management of per-station state.
- 802.11 station association processing; particularly useful to see when stations join and leave a BSS.
- 802.11 station authentication processing.
- scanning operation; especially useful for debugging problems with not locating an access point.
- errors encountered during output handling.
- wlan(4) state machine operation.
- 802.11 power save operation; in hostap mode this enables copious information about buffered frames for stations operating in power save mode.
- trace operation of Hybrid Wireless Mesh Protocol processing.
- 802.1x state machine operation; not presently meaningful as 802.1x protocol support is implemented in user mode by the hostapd(8) program.
- radius backend operation as it relates to 802.1x operation; not presently meaningful as 802.1x protocol support is implemented in user mode by the hostapd(8) program.
- dump packets exchanged with the radius backend for 802.1x operation; not presently meaningful as 802.1x protocol support is implemented in user mode by the hostapd(8) program.
- trace operation of 802.11s mesh protocol processing.
- trace operation of the WPA protocol; only partly meaningful as WPA protocol support is mostly implemented in user mode by the hostapd(8) and wpa_supplicant(8) programs.
- trace operation of the Access Control List (ACL) support; see wlan_acl(4) for more details.
- trace operation of WME/WMM protocol processing.
- trace operation of Atheros SuperG protocol processing.
- trace operation of IEEE 802.11h protocol processing.
- trace station inactivity processing; in particular, show when stations associated to an access point are dropped due to inactivity.
- trace station mode roaming between access points.
- trace transmit rate control operation.
EXAMPLESThe following might be used to debug basic station mode operation:
wlandebug -i ral0 scan+auth+assoc
it enables debug messages while scanning, authenticating to an access point, and associating to an access point.
NOTESDifferent wireless drivers support different debugging messages. Drivers such as ath(4) and ral(4) that depend on the wlan(4) module for 802.11 protocol processing typically support most of the debugging messages while devices that implement parts of the 802.11 protocol in firmware do not.
|July 17, 2009||FreeBSD|