|UEFI(8)||FreeBSD System Manager's Manual||UEFI(8)|
NAMEUEFI — Unified Extensible Firmware Interface bootstrapping procedures
DESCRIPTIONThe UEFI Unified Extensible Firmware Interface provides boot- and run-time services to operating systems. UEFI is a replacement for the legacy BIOS on the i386 and amd64 CPU architectures, and is also used on arm64 and ia64.
The UEFI boot process loads system bootstrap code located in an EFI System Partition (ESP). The ESP is a GPT or MBR partition with a specific identifier that contains an msdosfs(5) FAT file system with a specified file hierarchy.
|Partition Scheme||ESP Identifier|
The UEFI boot process proceeds as follows:
- UEFI firmware runs at power up and searches for an OS loader in the EFI system partition. The path to the loader may be set by an EFI environment variable. If not set, the default is /EFI/BOOT/BOOTX64.EFI. The default UEFI boot configuration for FreeBSD installs boot1.efi as /EFI/BOOT/BOOTX64.EFI.
- boot1.efi locates the first partition with the type
freebsd-ufs, and from it loads loader.efi.
- loader.efi loads and boots the kernel, as described in loader(8).
The vt(4) system console is automatically selected when booting via UEFI.
- First stage UEFI bootstrap
- msdosfs(5) FAT file system image containing boot1.efi for use by bsdinstall(8) and the bootcode argument to gpart(8).
- Final stage bootstrap
- default kernel
- typical non-default kernel (optional)
HISTORYUEFI boot support first appeared in FreeBSD 10.1.
AUTHORSUEFI boot support was developed by < benno@FreeBSD.org>, < emaste@FreeBSD.org>, and < nwhitehorn@FreeBSD.org>. The FreeBSD Foundation sponsored portions of the work.
CAVEATSEFI environment variables are not supported by loader(8) or the kernel.
boot1.efi loads loader.efi from the first FreeBSD-UFS file system it locates, even if it is on a different disk.
boot1.efi cannot load loader.efi from a ZFS(8) file system. As a result, UEFI does not support a typical root file system on ZFS configuration.
|October 17, 2014||FreeBSD|