|SWAPON(8)||FreeBSD System Manager's Manual||SWAPON(8)|
NAMEswapon, swapoff, swapctl — specify devices for paging and swapping
|swapon||[ -F fstab] -aLq | file ...|
|swapoff||[ -F fstab] -aLq | file ...|
|swapctl||[ -AghklmsU][ -a file ... | -d file ...]|
DESCRIPTIONThe swapon, swapoff and swapctl utilities are used to control swap devices in the system. At boot time all swap entries in /etc/fstab are added automatically when the system goes multi-user. Swap devices use a fixed interleave; the maximum number of devices is unlimited. There is no priority mechanism.
The swapon utility adds the specified swap devices to the system. If the -a option is used, all swap devices in /etc/fstab will be added, unless their “noauto” or “late” option is also set. If the -L option is specified, swap devices with the “late” option will be added as well as ones with no option. If the -q option is used, informational messages will not be written to standard output when a swap device is added.
The swapoff utility removes the specified swap devices from the system. If the -a option is used, all swap devices in /etc/fstab will be removed, unless their “noauto” or “late” option is also set. If the -L option is specified, swap devices with the “late” option will be removed as well as ones with no option. If the -q option is used, informational messages will not be written to standard output when a swap device is removed. Note that swapoff will fail and refuse to remove a swap device if there is insufficient VM (memory + remaining swap devices) to run the system. The swapoff utility must move swapped pages out of the device being removed which could lead to high system loads for a period of time, depending on how much data has been swapped out to that device.
Other options supported by both swapon and swapoff are as follows:
- -F fstab
- Specify the fstab file to use.
The swapctl utility exists primarily for those familiar with other BSDs and may be used to add, remove, or list swap devices. Note that the -a option is used differently in swapctl and indicates that a specific list of devices should be added. The -d option indicates that a specific list should be removed. The -A and -U options to swapctl operate on all swap entries in /etc/fstab which do not have their “noauto” option set.
Swap information can be generated using the swapinfo(8) utility, pstat -s, or swapctl -l. The swapctl utility has the following options for listing swap:
- Output values in human-readable form.
- Output values in gigabytes.
- Output values in kilobytes.
- Output values in megabytes.
- List the devices making up system swap.
Print a summary line for system swap.
The BLOCKSIZE environment variable is used if not specifically overridden. 512 byte blocks are used by default.
- standard paging devices
- memory disk devices
- ASCII file system description table
DIAGNOSTICSThese utilities may fail for the reasons described in swapon(2).
HISTORYThe swapon utility appeared in 4.0BSD. The swapoff and swapctl utilities appeared in FreeBSD 5.1.
|November 22, 2013||FreeBSD|