|SICONTROL(8)||FreeBSD System Manager's Manual||SICONTROL(8)|
NAMEsicontrol — Specialix SI/XIO driver configuration and debugging
|sicontrol||device command [ param ...]|
DESCRIPTIONThe sicontrol utility is used to configure and monitor the SI/XIO device driver.
The sicontrol utility operates on the specified device to indicate which port is to be used.
The special device string `-' is used to indicate the global driver settings instead.
A /dev/ is included if necessary.
The following commands are used for the global settings and should be specified with the '-' device name:
- int_throttle [ value]
Configure the `aggregate interrupt throttle value'. The maximum number of host adapter interrupts per second is determined by:
controller CPU clock / (8 * int_throttle)
The default value at boot time is 25000. The host adapter cpu clock is 25MHz. This gives a maximum interrupt rate of about 125 interrupts per second.
Lowering this value will increase the rate in which the host adapter can interrupt the operating system for attention.
- rxint_throttle [ value]
Configure the receiver interrupt throttle value. The default value of 4 at boot time allows an interrupt rate of approximately 25.
Lowering this value will increase the rate in which the host adapter can interrupt the operating system to empty the receiver fifos.
- Return the number of ports under the control of the device driver.
The following commands are used for the individual ports and should be specified with a device name from /dev:
- Show the current incoming modem control signals.
- Show the current "ccb" structure for the specified port. This is not of much use outside of debugging the driver and determining why a port is wedged.
DIAGNOSTICSGenerally self explanatory.....
HISTORYThe sicontrol utility is loosely based on a utility called siconfig which was written by <firstname.lastname@example.org>
Specialix International do not support this device driver in any way.
BUGSBound to be many... :-)
|September 26, 1995||FreeBSD|